Paper/Archive/CVE-2026-77405

CVE-2026-77405

rabbitmq amqp091-go — RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser

Description · from the CVE record

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.

Affected

ProductAffectedFixed inSource
amqp091-go< 1.13.0–CNA

Scores by source

GitHub_M (CNA)9.4CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:N
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

refgithub.com/rabbitmq/amqp091-go/security/advisories/GHSA-33mj-cw25-m34hrefgithub.com/rabbitmq/amqp091-go/pull/355refgithub.com/rabbitmq/amqp091-go/commit/c9fd433ecac2e557919e51acc9d809390c402c6erefgithub.com/rabbitmq/amqp091-go/releases/tag/v1.13.0