CVE-2026-59084
Apache Software Foundation Apache Tomcat — Apache Tomcat: EncryptInterceptor requirements not clearly documented
Description · from the CVE record
Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.
Affected
ProductAffectedFixed inSource
Apache Tomcat11.0.0-M1 – 11.0.23–CNA
Apache Tomcat10.1.0-M1 – 10.1.56–CNA
Apache Tomcat9.0.13 – 9.0.119–CNA
Apache Tomcat8.5.38 – 8.5.100–CNA
Apache Tomcat7.0.100 – 7.0.109–CNA
Scores by source
CISA ADP9.1CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total