Paper/Archive/CVE-2026-49871

CVE-2026-49871

Apache Software Foundation Apache APISIX — Apache APISIX: cas-auth login CSRF / session injection issue

Description · from the CVE record

Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected

ProductAffectedFixed inSource
Apache APISIX3.0.0 – 3.16.0–CNA

Scores by source

NVD9.3CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
apache (CNA)2.1CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: partial

References

refopenwall.com/lists/oss-security/2026/06/19/14advisorylists.apache.org/thread/1ozsnss0lof4gpwq763d66oxwxt3sycp