Paper/Archive/CVE-2026-49230

CVE-2026-49230

Apache Software Foundation Apache APISIX — Apache APISIX: Authentication bypass in jwe-decrypt

Description · from the CVE record

Improper Validation of Integrity Check Value vulnerability in Apache APISIX. The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass.  This issue affects Apache APISIX: from 3.8.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected

ProductAffectedFixed inSource
Apache APISIX3.8.0 – 3.16.0–CNA

Scores by source

NVD9.1CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
apache (CNA)6.3CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: partial

References

advisorylists.apache.org/thread/n0blgkpvz38ghh5rrh6wtl476919xj1brefopenwall.com/lists/oss-security/2026/06/19/12