Paper/Archive/CVE-2026-43944

CVE-2026-43944

electerm electerm — electerm: dangerous code can be run through links or command line

Description · from the CVE record

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.

Affected

ProductAffectedFixed inSource
electerm>= 3.0.6, < 3.8.15–CNA

Scores by source

NVD9.6CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
GitHub_M (CNA)9.4CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: total

References

refgithub.com/electerm/electerm/security/advisories/GHSA-mpm8-cx2p-626qrefgithub.com/electerm/electerm/commit/0599e67069b00e376a2e962649aaad6096e63507refgithub.com/electerm/electerm/commit/8a6a17951e96d715f5a231532bbd8303fe208700refgithub.com/electerm/electerm/commit/a79e06f4a1f0ac6376c3d2411ef4690fa0377742refgithub.com/electerm/electerm/releases/tag/v3.8.15