Paper/Archive/CVE-2026-43515

CVE-2026-43515

Apache Software Foundation Apache Tomcat — Apache Tomcat: Security constraints not correctly applied

Description · from the CVE record

Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

Affected

ProductAffectedFixed inSource
Apache Tomcat11.0.0-M1 – 11.0.21–CNA
Apache Tomcat10.1.0-M1 – 10.1.54–CNA
Apache Tomcat9.0.0.M1 – 9.0.117–CNA
Apache Tomcat8.5.0 – 8.5.100–CNA
Apache Tomcat7.0.0 – 7.0.109–CNA

Scores by source

CISA ADP9.1CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

advisorylists.apache.org/thread/746nxfxod0wsocxtmv8pb8nkgmwpc6bbrefopenwall.com/lists/oss-security/2026/05/12/11