Description · from the CVE record
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module. This vulnerability exists when the rewrite directive is followed by a rewrite, if, or set directive and an unnamed Perl-Compatible Regular Expression (PCRE) capture (for example, $1, $2) with a replacement string that includes a question mark (?). An unauthenticated attacker along with conditions beyond its control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected
ProductAffectedFixed inSource
NGINX PlusR36 – < R36 P4R36 P4CNA
NGINX PlusR32 – < R32 P6R32 P6CNA
NGINX Open Source0.6.27 – < 1.30.11.30.1CNA
Red Hat Enterprise Linux 10see advisory2:1.26.3-2.el10_1.2redhat-SADP
Red Hat Enterprise Linux 10.0 Extended Update Supportsee advisory2:1.26.3-1.el10_0.9redhat-SADP
Red Hat Enterprise Linux 8see advisory8100020260514165201.489197e6redhat-SADP
Red Hat Enterprise Linux 9see advisory2:1.20.1-24.el9_7.3redhat-SADP
Red Hat Enterprise Linux 9see advisory9080020260514160836.9redhat-SADP
Red Hat Enterprise Linux 9see advisory9080020260514152324.9redhat-SADP
Red Hat Enterprise Linux 9.0 Update Services for SAP Solutionssee advisory1:1.20.1-10.el9_0.4redhat-SADP
Red Hat Enterprise Linux 9.2 Update Services for SAP Solutionssee advisory1:1.20.1-14.el9_2.6redhat-SADP
Red Hat Enterprise Linux 9.4 Extended Update Supportsee advisory1:1.20.1-16.el9_4.6redhat-SADP
Scores by source
f5 (CNA)9.2CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
f5 (CNA)8.1CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
redhat-SADP (CNA)8.1CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: total