Description · from the CVE record

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.

Affected

ProductAffectedFixed inSource
litellm>= 1.81.16, < 1.83.7–CNA
Lightspeed Coresee advisory–redhat-SADP
Red Hat Ansible Automation Platform 2see advisory–redhat-SADP
Red Hat OpenShift AI (RHOAI)see advisory–redhat-SADP
Red Hat OpenShift AI (RHOAI)see advisory–redhat-SADP

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
redhat-SADP (CNA)9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)9.3CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CISA ADPSSVCExploitation: active · Automatable: yes · Technical impact: total

References

refgithub.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmcrefgithub.com/BerriAI/litellm/releases/tag/v1.83.7-stablerefcisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42208refaccess.redhat.com/security/cve/CVE-2026-42208refbugzilla.redhat.com/show_bug.cgi?id=2463965refsecurity.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42208.jsonkevcisa.gov/known-exploited-vulnerabilities-catalog