Paper/Archive/CVE-2026-41871

CVE-2026-41871

Apache Software Foundation Apache Nutch — Apache Nutch: Unauthenticated reflection-based job execution in Nutch Server (Nutch REST API)

Description · from the CVE record

Missing Authorization, Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Nutch Server (Nutch REST API). This issue affects Apache Nutch: from 1.10 through 1.22. Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

Affected

ProductAffectedFixed inSource
Apache Nutch1.10 – 1.22–CNA

Scores by source

CISA ADP9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

advisorylists.apache.org/thread/rbr63fx8vlrhzrfknq2l0mg0d0blsl54refopenwall.com/lists/oss-security/2026/09/08/5