Paper/Archive/CVE-2026-41500

CVE-2026-41500

electerm electerm — electerm has Command Injection Vulnerability via runMac function

Description · from the CVE record

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:150. The runMac() function appends attacker-controlled remote releaseInfo.name directly into an exec("open ...") command without validation. This issue has been patched in version 3.3.8.

Affected

ProductAffectedFixed inSource
electerm< 3.3.8–CNA

Scores by source

GitHub_M (CNA)9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

refgithub.com/electerm/electerm/security/advisories/GHSA-wxw2-rwmh-vr8frefgithub.com/electerm/electerm/commit/59708b38c8a52f5db59d7d4eff98e31d573128eerefgithub.com/electerm/electerm/releases/tag/v3.3.8