Paper/Archive/CVE-2026-33804

CVE-2026-33804

@fastify/middie @fastify/middie — @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

Description · from the CVE record

@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

Affected

ProductAffectedFixed inSource
@fastify/middie< 9.3.29.3.2CNA

Scores by source

NVD9.1CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
openjs (CNA)7.4CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: total

References

refgithub.com/fastify/middie/security/advisories/GHSA-v9ww-2j6r-98q6refcna.openjsf.org/security-advisories.html