Paper/Archive/CVE-2026-32248

CVE-2026-32248

parse-community parse-server — Parse Server: Account takeover via operator injection in authentication data identifier

Description · from the CVE record

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.12 and 8.6.38, an unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable. This vulnerability is fixed in 9.6.0-alpha.12 and 8.6.38.

Affected

ProductAffectedFixed inSource
parse-server>= 9.0.0, < 9.6.0-alpha.12–CNA
parse-server< 8.6.38–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)9.3CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

refgithub.com/parse-community/parse-server/security/advisories/GHSA-5fw2-8jcv-xh87refgithub.com/parse-community/parse-server/releases/tag/8.6.38refgithub.com/parse-community/parse-server/releases/tag/9.6.0-alpha.12