Paper/Archive/CVE-2026-31908

CVE-2026-31908

Apache Software Foundation Apache APISIX — Apache APISIX: forward auth plugin allows header injection

Description · from the CVE record

Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Affected

ProductAffectedFixed inSource
Apache APISIX2.12.0 – 3.15.0–CNA

Scores by source

CISA ADP9.1CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

advisorylists.apache.org/thread/sob643s5lztov7x579j8o0c444t36n6brefopenwall.com/lists/oss-security/2026/04/14/3