Paper/Archive/CVE-2026-27971

CVE-2026-27971

QwikDev qwik — Qwik affected by unauthenticated RCE via server$ Deserialization

Description · from the CVE record

Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.

Affected

ProductAffectedFixed inSource
qwik< 1.19.1–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)9.2CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: total

References

refgithub.com/QwikDev/qwik/security/advisories/GHSA-p9x5-jp3h-96mm