Paper/Archive/CVE-2026-24009

CVE-2026-24009

docling-project docling-core — Docling Core vulnerable to Remote Code Execution via unsafe PyYAML usage

Description · from the CVE record

Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.

Affected

ProductAffectedFixed inSource
docling-core>= 2.21.0, < 2.48.4–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)8.1CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: total

References

refgithub.com/docling-project/docling-core/security/advisories/GHSA-vqxf-v2gg-x3hcrefgithub.com/docling-project/docling-core/issues/482refgithub.com/docling-project/docling-core/commit/3e8d628eeeae50f0f8f239c8c7fea773d065d80crefgithub.com/advisories/GHSA-8q59-q68h-6hv4refgithub.com/docling-project/docling-core/releases/tag/v2.48.4