Paper/Archive/CVE-2026-22034

CVE-2026-22034

jvoisin snuffleupagus — Snuffleupagus vulnerable to RCE on instances with upload validation enabled but without the VLD package

Description · from the CVE record

Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system. On deployments of Snuffleupagus prior to version 0.13.0 with the non-default upload validation feature enabled and configured to use one of the upstream validation scripts based on Vulcan Logic Disassembler (VLD) while the VLD extension is not available to the CLI SAPI, all files from multipart POST requests are evaluated as PHP code. The issue was fixed in version 0.13.0.

Affected

ProductAffectedFixed inSource
snuffleupagus< 0.13.0–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)9.2CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CISA ADPSSVCExploitation: poc · Automatable: yes · Technical impact: total

References

refgithub.com/jvoisin/snuffleupagus/security/advisories/GHSA-c4ch-xw5p-2mvcrefgithub.com/jvoisin/snuffleupagus/commit/9278dc77bab2a219e770a1b31dd6797bc9070e37refgithub.com/jvoisin/snuffleupagus/blob/9278dc77bab2a219e770a1b31dd6797bc9070e37/src/sp_upload_validation.c#L92-L100refgithub.com/jvoisin/snuffleupagus/blob/v0.12.0/scripts/upload_validation.phprefgithub.com/jvoisin/snuffleupagus/blob/v0.12.0/scripts/upload_validation.pyrefgithub.com/php/php-src/blob/e4098da58a9eaee759d728d98a27d809cde37671/ext/standard/dl.c#L165-L166refgithub.com/php/php-src/blob/e4098da58a9eaee759d728d98a27d809cde37671/main/rfc1867.c#L1269-L1274refsnuffleupagus.readthedocs.io/config.html#upload-validation