Paper/Archive/CVE-2026-18245

CVE-2026-18245

AWS Amplify Codegen UI — Incomplete fix for CVE-2025-4318 code injection in Amazon @aws-amplify/codegen-ui-react

Description · from the CVE record

Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318. To remediate this issue, users should upgrade to version 2.20.6

Affected

ProductAffectedFixed inSource
Amplify Codegen UI< 2.20.62.20.6CNA

Scores by source

AMZN (CNA)9.0CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
AMZN (CNA)6.4CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: total

References

patchgithub.com/aws-amplify/amplify-codegen-ui/releases/tag/v2.20.6advisoryaws.amazon.com/security/security-bulletins/2026-066-awswriteupgithub.com/aws-amplify/amplify-codegen-ui/security/advisories/GHSA-74xx-rjgf-m69j