Paper/Archive/CVE-2026-115915

CVE-2026-115915

vllm-project vllm — vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

Description · from the CVE record

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

Affected

ProductAffectedFixed inSource
vllm< 0.32.0–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)8.1CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: total

References

refgithub.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3hrefgithub.com/vllm-project/vllm/pull/60022refgithub.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fdrefgithub.com/vllm-project/vllm/releases/tag/v0.32.0