CVE-2025-9803
lunary-ai lunary-ai/lunary — Improper Authentication in lunary-ai/lunary
Description · from the CVE record
lunary-ai/lunary version 1.9.34 is vulnerable to an account takeover due to improper authentication in the Google OAuth integration. The application fails to verify the 'aud' (audience) field in the access token issued by Google, which is crucial for ensuring the token is intended for the application. This oversight allows attackers to use tokens issued to malicious applications to gain unauthorized access to user accounts. The issue is resolved in version 1.9.35.
Affected
ProductAffectedFixed inSource
lunary-ai/lunaryunspecified – < 1.9.351.9.35CNA
Scores by source
@huntr_ai (CNA)9.3CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
CISA ADPSSVCExploitation: poc · Automatable: no · Technical impact: total