Paper/Archive/CVE-2025-69222

CVE-2025-69222

danny-avila LibreChat — LibreChat is vulnerable to Server-Side Request Forgery due to missing restrictions

Description · from the CVE record

LibreChat is a ChatGPT clone with additional features. Version 0.8.1-rc2 is prone to a server-side request forgery (SSRF) vulnerability due to missing restrictions of the Actions feature in the default configuration. LibreChat enables users to configure agents with predefined instructions and actions that can interact with remote services via OpenAPI specifications, supporting various HTTP methods, parameters, and authentication methods including custom headers. By default, there are no restrictions on accessible services, which means agents can also access internal components like the RAG API included in the default Docker Compose setup. This issue is fixed in version 0.8.1-rc2.

Affected

ProductAffectedFixed inSource
LibreChat>= 0.8.1-rc2, 0.8.2-rc2–CNA

Scores by source

GitHub_M (CNA)9.1CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
CISA ADPSSVCExploitation: poc · Automatable: no · Technical impact: partial

References

refgithub.com/danny-avila/LibreChat/security/advisories/GHSA-rgjq-4q58-m3q8refgithub.com/danny-avila/LibreChat/commit/3b41e392ba5c0d603c1737d8582875e04eaa6e02refgithub.com/danny-avila/LibreChat/releases/tag/v0.8.2-rc2