Description · from the CVE record

net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.

Affected

ProductAffectedFixed inSource
net-snmp< 5.9.5–CNA
net-snmp>= 5.10.pre1, < 5.10.pre2–CNA

Scores by source

GitHub_M (CNA)9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

refgithub.com/net-snmp/net-snmp/security/advisories/GHSA-4389-rwqf-q9gqreflists.debian.org/debian-lts-announce/2026/01/msg00000.htmlrefopenwall.com/lists/oss-security/2026/01/09/2refvicarius.io/vsociety/posts/cve-2025-68615-detection-script-buffer-overflow-vulnerability-affecting-net-snmprefvicarius.io/vsociety/posts/cve-2025-68615-mitigation-script-buffer-overflow-vulnerability-affecting-net-snmp