Paper/Archive/CVE-2025-58360

CVE-2025-58360

geoserver geoserver — GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature

Description · from the CVE record

GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

Affected

ProductAffectedFixed inSource
geoserver>= 2.26.0, < 2.26.2–CNA
geoserver< 2.25.6–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)8.2CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
CISA ADPSSVCExploitation: active · Automatable: yes · Technical impact: partial

References

refgithub.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525refosgeo-org.atlassian.net/browse/GEOS-11682refcisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-58360kevcisa.gov/known-exploited-vulnerabilities-catalog