Paper/Archive/CVE-2025-54988

CVE-2025-54988

Apache Software Foundation Apache Tika PDF parser module — Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA

Description · from the CVE record

Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.

Affected

ProductAffectedFixed inSource
Apache Tika PDF parser module1.13 – 3.2.1–CNA

Scores by source

CISA ADP9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
apache (CNA)8.4CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: poc · Automatable: no · Technical impact: total

References

advisorylists.apache.org/thread/8xn3rqy6kz5b3l1t83kcofkw0w4mmj1wreflists.debian.org/debian-lts-announce/2025/10/msg00030.htmlrefopenwall.com/lists/oss-security/2025/08/20/2refopenwall.com/lists/oss-security/2025/08/20/3