Paper/Archive/CVE-2025-48877

CVE-2025-48877

discourse discourse — Discourse vulnerable to auto-executing of third-party code in embedded CodePen iframe

Description · from the CVE record

Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, Codepen is present in the default `allowed_iframes` site setting, and it can potentially auto-run arbitrary JS in the iframe scope, which is unintended. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. As a workaround, the Codepen prefix can be removed from a site's `allowed_iframes`.

Affected

ProductAffectedFixed inSource
discourse< 3.4.4–CNA
discourse< 3.5.0.beta5–CNA
discourse< 3.5.0.beta6-dev–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)8.1CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: partial

References

refgithub.com/discourse/discourse/security/advisories/GHSA-cm93-6m2m-cjcv