Description · from the CVE record

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.

Affected

ProductAffectedFixed inSource
cms>= 3.0.0-RC1, < 3.9.15–CNA
cms>= 4.0.0-RC1, < 4.14.15–CNA
cms>= 5.0.0-RC1, < 5.6.17–CNA

Scores by source

GitHub_M (CNA)10.0CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
CISA ADPSSVCExploitation: active · Automatable: yes · Technical impact: total

References

refgithub.com/craftcms/cms/security/advisories/GHSA-f3gw-9ww9-jmc3refgithub.com/craftcms/cms/commit/e1c85441fa47eeb7c688c2053f25419bc0547b47refgithub.com/craftcms/cms/blob/3.x/CHANGELOG.md#3915---2025-04-10-criticalrefgithub.com/craftcms/cms/blob/4.x/CHANGELOG.md#41415---2025-04-10-criticalrefgithub.com/craftcms/cms/blob/5.x/CHANGELOG.md#5617---2025-04-10-criticalexploitsensepost.com/blog/2025/investigating-an-in-the-wild-campaign-using-rce-in-craftcmsrefcisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-32432kevcisa.gov/known-exploited-vulnerabilities-catalog