Paper/Archive/CVE-2025-29927

CVE-2025-29927

vercel next.js — Authorization Bypass in Next.js Middleware

Description · from the CVE record

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

Affected

ProductAffectedFixed inSource
next.js>= 11.1.4, < 12.3.5–CNA
next.js>= 14.0.0, < 14.2.25–CNA
next.js>= 15.0.0, < 15.2.3–CNA
next.js>= 13.0.0, < 13.5.9–CNA

Scores by source

GitHub_M (CNA)9.1CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

refgithub.com/vercel/next.js/security/advisories/GHSA-f82v-jwr5-mffwrefgithub.com/vercel/next.js/commit/52a078da3884efe6501613c7834a3d02a91676d2refgithub.com/vercel/next.js/commit/5fd3ae8f8542677c6294f32d18022731eab6fe48refgithub.com/vercel/next.js/releases/tag/v12.3.5refgithub.com/vercel/next.js/releases/tag/v13.5.9refopenwall.com/lists/oss-security/2025/03/23/3refopenwall.com/lists/oss-security/2025/03/23/4refsecurity.netapp.com/advisory/ntap-20250328-0002