Paper/Archive/CVE-2025-15444

CVE-2025-15444

IAMB Crypt::Sodium::XS — Crypt::Sodium::XS module versions prior to 0.000042, for Perl, include a vulnerable version of libsodium

Description · from the CVE record

Crypt::Sodium::XS module versions prior to 0.000042, for Perl, include a vulnerable version of libsodium libsodium <= 1.0.20 or a version of libsodium released before December 30, 2025 contains a vulnerability documented as CVE-2025-69277  https://www.cve.org/CVERecord?id=CVE-2025-69277 . The libsodium vulnerability states: In atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group. 0.000042 includes a version of libsodium updated to 1.0.20-stable, released January 3, 2026, which includes a fix for the vulnerability.

Affected

ProductAffectedFixed inSource
Crypt::Sodium::XS< 0.0000420.000042CNA

Scores by source

CISA ADP9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

refgithub.com/jedisct1/libsodium/commit/ad3004ec8731730e93fcfbbc824e67eadc1c1baeref00f.net/2025/12/30/libsodium-vulnerabilityrefmetacpan.org/dist/Crypt-Sodium-XS/changes