Paper/Archive/CVE-2025-10226

CVE-2025-10226

AxxonSoft AxxonOne C-Werk — PostgreSQL Upgrade from v10 to v17.4 in AxxonSoft Axxon One (C-Werk) 2.0.8 and earlier to Address Multiple Vulnerabilities

Description · from the CVE record

Dependency on Vulnerable Third-Party Component (CWE-1395) in the PostgreSQL backend in AxxonSoft Axxon One (C-Werk) 2.0.8 and earlier on Windows and Linux allows a remote attacker to escalate privileges, execute arbitrary code, or cause denial-of-service via exploitation of multiple known CVEs present in PostgreSQL v10.x, which are resolved in PostgreSQL 17.4.

Affected

ProductAffectedFixed inSource
AxxonOne C-Werk≤ 2.0.8–CNA

Scores by source

AxxonSoft (CNA)9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
AxxonSoft (CNA)9.3CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

refaxxonsoft.com/legal/axxonsoft-vulnerability-disclosure-policy/security-advisoriesrefpostgresql.org/docs/release