Paper/Archive/CVE-2024-56145

CVE-2024-56145

craftcms cms — RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms

Description · from the CVE record

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.

Affected

ProductAffectedFixed inSource
cms>= 4.0.0-RC1, < 4.13.2–CNA
cms>= 5.0.0-RC1, < 5.5.2–CNA
cms>= 3.0.0, < 3.9.14–CNA

Scores by source

GitHub_M (CNA)9.3CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CISA ADPSSVCExploitation: active · Automatable: yes · Technical impact: total

References

refgithub.com/craftcms/cms/security/advisories/GHSA-2p6p-9rc9-62j9refgithub.com/craftcms/cms/commit/82e893fb794d30563da296bca31379c0df0079b3exploitgithub.com/Chocapikk/CVE-2024-56145refcisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-56145kevcisa.gov/known-exploited-vulnerabilities-catalog