CVE-2024-51567
cyberpanel cyberpanel — CyberPanel Incorrect Default Permissions Vulnerability
Description · from the CVE record
upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.
Affected
ProductAffectedFixed inSource
n/an/a–CNA
cyberpanel≤ 5b08cd6–CISA-ADP
Scores by source
mitre (CNA)10.0CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:N/S:C/UI:N
CISA ADPSSVCExploitation: active · Automatable: yes · Technical impact: total