CVE-2024-48514
maestroerror php-heic-to-jpg — php-heic-to-jpg <= 1.0.5 is vulnerable to code injection (fixed in 1.0.6).
Description · from the CVE record
php-heic-to-jpg <= 1.0.5 is vulnerable to code injection (fixed in 1.0.6). An attacker who can upload heic images is able to execute code on the remote server via the file name. As a result, the CIA is no longer guaranteed. This affects php-heic-to-jpg 1.0.5 and below.
Affected
ProductAffectedFixed inSource
n/an/a–CNA
php-heic-to-jpg≤ 1.0.5–CISA-ADP
Scores by source
CISA ADP9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: poc · Automatable: yes · Technical impact: total