CVE-2024-45409
SAML-Toolkits ruby-saml — The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector
Description · from the CVE record
The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.
Affected
ProductAffectedFixed inSource
ruby-saml< 1.12.3–CNA
ruby-saml>= 1.13.0, < 1.17.0–CNA
ruby-saml< 1.12.31.12.3CISA-ADP
ruby-saml1.13.0 – < 1.17.01.17.0CISA-ADP
omniauth-saml≤ 2.1.0–CISA-ADP
Scores by source
GitHub_M (CNA)10.0CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: poc · Automatable: yes · Technical impact: total