Paper/Archive/CVE-2024-3203

CVE-2024-3203

VulDB — c-blosc2 ndlz8x8.c ndlz8_decompress heap-based overflow

Description · from the CVE record

A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.

Affected

ProductAffectedFixed inSource
c-blosc22.13.0–CNA
c-blosc22.13.1–CNA
c-blosc22.13.2–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
VulDB (CNA)7.3CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
VulDB (CNA)7.3CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: partial

References

writeupvuldb.com/?id.259050refvuldb.com/?ctiid.259050writeupvuldb.com/?submit.304556exploitdrive.google.com/drive/folders/1T1k3UeS09m65LjVXExUuZfedNQPWQWCo?usp=sharingpatchgithub.com/Blosc/c-blosc2/releases/tag/v2.14.3