Paper/Archive/CVE-2024-31866

CVE-2024-31866

Apache Software Foundation Apache Zeppelin — Apache Zeppelin: Interpreter download command does not escape malicious code injection

Description · from the CVE record

Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Affected

ProductAffectedFixed inSource
Apache Zeppelin0.8.2 – < 0.11.10.11.1CNA
apache_zeppelin0.8.2 – < 0.11.10.11.1CISA-ADP

Scores by source

CISA ADP9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

patchgithub.com/apache/zeppelin/pull/4715advisorylists.apache.org/thread/jpkbq3oktopt34x2n5wnhzc2r1410dddrefopenwall.com/lists/oss-security/2024/04/09/10