Description · from the CVE record

OpenFGA is a high-performance and flexible authorization/permission engine. Some end users of OpenFGA v1.5.0 or later are vulnerable to authorization bypass when calling Check or ListObjects APIs. You are very likely affected if your model involves exclusion (e.g. `a but not b`) or intersection (e.g. `a and b`). This vulnerability is fixed in v1.5.3.

Affected

ProductAffectedFixed inSource
openfga>= 1.5.0, < 1.5.3–CNA
openfga1.5.0 – < 1.5.31.5.3CISA-ADP

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)8.1CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: total

References

refgithub.com/openfga/openfga/security/advisories/GHSA-8cph-m685-6v6rrefgithub.com/openfga/openfga/commit/b6a6d99b2bdbf8c3781503989576076289f48ed2