Paper/Archive/CVE-2024-31211

CVE-2024-31211

WordPress wordpress-develop — Remote Code Execution in `WP_HTML_Token`

Description · from the CVE record

WordPress is an open publishing platform for the Web. Unserialization of instances of the `WP_HTML_Token` class allows for code execution via its `__destruct()` magic method. This issue was fixed in WordPress 6.4.2 on December 6th, 2023. Versions prior to 6.4.0 are not affected.

Affected

ProductAffectedFixed inSource
wordpress-develop>= 6.4.0 < 6.4.2–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)5.5CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: partial

References

refgithub.com/WordPress/wordpress-develop/security/advisories/GHSA-m257-q4m5-j653