Paper/Archive/CVE-2024-27135

CVE-2024-27135

Apache Software Foundation Apache Pulsar — Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution

Description · from the CVE record

Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected

ProductAffectedFixed inSource
Apache Pulsar2.4.0 – < 2.10.62.10.6CNA
Apache Pulsar2.11.0 – < 2.11.42.11.4CNA
Apache Pulsar3.0.0 – < 3.0.33.0.3CNA
Apache Pulsar3.1.0 – < 3.1.33.1.3CNA
Apache Pulsar3.2.0 – < 3.2.13.2.1CNA
pulsar2.4.0 – < 2.10.62.10.6CISA-ADP
pulsar2.11.0 – < 2.11.42.11.4CISA-ADP
pulsar3.0.0 – < 3.0.33.0.3CISA-ADP
pulsar3.1.0 – < 3.1.33.1.3CISA-ADP
pulsar3.2.0 – < 3.2.13.2.1CISA-ADP

Scores by source

NVD9.9CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
apache (CNA)8.5CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: total

References

reflists.apache.org/thread/dh8nj2vmb2br6thjltq74lk9jxkz62wnadvisorypulsar.apache.org/security/CVE-2024-27135refopenwall.com/lists/oss-security/2024/03/12/9