Paper/Archive/CVE-2024-12029

CVE-2024-12029

invoke-ai invoke-ai/invokeai — Remote Code Execution via Model Deserialization in invoke-ai/invokeai

Description · from the CVE record

A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.

Affected

ProductAffectedFixed inSource
invoke-ai/invokeaiunspecified – < 5.4.35.4.3CNA

Scores by source

@huntr_ai (CNA)9.8CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: poc · Automatable: yes · Technical impact: total

References

exploithuntr.com/bounties/9b790f94-1b1b-4071-bc27-78445d1a87a3refgithub.com/invoke-ai/invokeai/commit/756008dc5899081c5aa51e5bd8f24c1b3975a59e