Paper/Archive/CVE-2023-47121

CVE-2023-47121

discourse discourse — Discourse SSRF vulnerability in Embedding

Description · from the CVE record

Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, the embedding feature is susceptible to server side request forgery. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. As a workaround, disable the Embedding feature.

Affected

ProductAffectedFixed inSource
discourse< 3.1.3–CNA
discourse>= 3.2.0.beta0, < 3.2.0.beta3–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)3.4CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: partial

References

refgithub.com/discourse/discourse/security/advisories/GHSA-hp24-94qf-8cgcrefgithub.com/discourse/discourse/commit/24cca10da731734af4e9748de99a508d586e59f1refgithub.com/discourse/discourse/commit/5f20748e402223b265e6fee381472c14e2604da6