CVE-2023-46604
Apache Software Foundation Apache ActiveMQ — Apache ActiveMQ, Apache ActiveMQ Legacy OpenWire Module: Unbounded deserialization causes ActiveMQ to be vulnerable to a remote code execution (RCE) attack
Description · from the CVE record
The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.
Affected
ProductAffectedFixed inSource
Apache ActiveMQ5.18.0 – < 5.18.35.18.3CNA
Apache ActiveMQ5.17.0 – < 5.17.65.17.6CNA
Apache ActiveMQ5.16.0 – < 5.16.75.16.7CNA
Apache ActiveMQ< 5.15.165.15.16CNA
Apache ActiveMQ Legacy OpenWire Module5.18.0 – < 5.18.35.18.3CNA
Apache ActiveMQ Legacy OpenWire Module5.17.0 – < 5.17.65.17.6CNA
Apache ActiveMQ Legacy OpenWire Module5.16.0 – < 5.16.75.16.7CNA
Apache ActiveMQ Legacy OpenWire Module5.8.0 – < 5.15.165.15.16CNA
Scores by source
apache (CNA)10.0CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H
CISA ADPSSVCExploitation: active · Automatable: yes · Technical impact: total