Paper/Archive/CVE-2023-31098

CVE-2023-31098

Apache Software Foundation Apache InLong — Apache InLong: Weak Password Implementation in InLong

Description · from the CVE record

Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.1.0 through 1.6.0.  When users change their password to a simple password (with any character or symbol), attackers can easily guess the user's password and access the account. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7805 https://github.com/apache/inlong/pull/7805 to solve it.

Affected

ProductAffectedFixed inSource
Apache InLong1.1.0 – 1.6.0–CNA
inlong1.1.0 – 1.6.0–CISA-ADP

Scores by source

CISA ADP9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

advisorylists.apache.org/thread/1fvloc3no1gbffzrcsx9ltsg08wr2d1w