Paper/Archive/CVE-2023-25157

CVE-2023-25157

geoserver geoserver — Unfiltered SQL Injection Vulnerabilities in Geoserver

Description · from the CVE record

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. GeoServer includes support for the OGC Filter expression language and the OGC Common Query Language (CQL) as part of the Web Feature Service (WFS) and Web Map Service (WMS) protocols. CQL is also supported through the Web Coverage Service (WCS) protocol for ImageMosaic coverages. Users are advised to upgrade to either version 2.21.4, or version 2.22.2 to resolve this issue. Users unable to upgrade should disable the PostGIS Datastore *encode functions* setting to mitigate ``strEndsWith``, ``strStartsWith`` and ``PropertyIsLike `` misuse and enable the PostGIS DataStore *preparedStatements* setting to mitigate the ``FeatureId`` misuse.

Affected

ProductAffectedFixed inSource
geoserver>= 2.22.0, < 2.22.2–CNA
geoserver< 2.21.4–CNA

Scores by source

GitHub_M (CNA)9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

refgithub.com/geoserver/geoserver/security/advisories/GHSA-7g5f-wrx8-5ccfrefgithub.com/geoserver/geoserver/commit/145a8af798590288d270b240235e89c8f0b62e1d