Paper/Archive/CVE-2023-22946

CVE-2023-22946

Apache Software Foundation Apache Spark — Apache Spark proxy-user privilege escalation from malicious configuration class

Description · from the CVE record

In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications. Update to Apache Spark 3.4.0 or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.

Affected

ProductAffectedFixed inSource
Apache Spark< 3.4.03.4.0CNA

Scores by source

NVD9.9CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
apache (CNA)6.4CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: partial

References

advisorylists.apache.org/thread/yllfl25xh5tbotjmg93zrq4bzwhqc0gv