Paper/Archive/CVE-2023-22727

CVE-2023-22727

cakephp cakephp — Database Query::offset() and limit() vulnerable to SQL injection in cakephp

Description · from the CVE record

CakePHP is a development framework for PHP web apps. In affected versions the `Cake\Database\Query::limit()` and `Cake\Database\Query::offset()` methods are vulnerable to SQL injection if passed un-sanitized user request data. This issue has been fixed in 4.2.12, 4.3.11, 4.4.10. Users are advised to upgrade. Users unable to upgrade may mitigate this issue by using CakePHP's Pagination library. Manually validating or casting parameters to these methods will also mitigate the issue.

Affected

ProductAffectedFixed inSource
cakephp>= 4.2.0, < 4.2.12–CNA
cakephp>= 4.3.0, < 4.3.11–CNA
cakephp>= 4.4.0, < 4.4.10–CNA

Scores by source

GitHub_M (CNA)9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

refgithub.com/cakephp/cakephp/security/advisories/GHSA-6g8q-qfpv-57wprefgithub.com/cakephp/cakephp/commit/3f463e7084b5a15e67205ced3a622577cca7a239refbakery.cakephp.org/2023/01/06/cakephp_4211_4311_4410_released.html