Paper/Archive/CVE-2023-20873

CVE-2023-20873

vmware — In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry c…

Description · from the CVE record

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.

Affected

ProductAffectedFixed inSource
Spring BootSpring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions–CNA

Scores by source

CISA ADP9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: total

References

refspring.io/security/cve-2023-20873refsecurity.netapp.com/advisory/ntap-20230601-0009refspring.io/blog/2023/05/18/spring-boot-2-5-15-and-2-6-15-available-now