CVE-2023-0109
usememos usememos/memos — Stored XSS in usememos/memos
Description · from the CVE record
A stored cross-site scripting (XSS) vulnerability was discovered in usememos/memos version 0.9.1. This vulnerability allows an attacker to upload a JavaScript file containing a malicious script and reference it in an HTML file. When the HTML file is accessed, the malicious script is executed. This can lead to the theft of sensitive information, such as login credentials, from users visiting the affected website. The issue has been fixed in version 0.10.0.
Affected
ProductAffectedFixed inSource
usememos/memosunspecified – < 0.10.00.10.0CNA
memos< 0.10.00.10.0CISA-ADP
Scores by source
@huntr_ai (CNA)9.8CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: poc · Automatable: no · Technical impact: partial