Paper/Archive/CVE-2022-45064

CVE-2022-45064

Apache Software Foundation Apache Sling Engine — Apache Sling Engine: Include-based XSS

Description · from the CVE record

The SlingRequestDispatcher doesn't correctly implement the RequestDispatcher API resulting in a generic type of include-based cross-site scripting issues on the Apache Sling level. The vulnerability is exploitable by an attacker that is able to include a resource with specific content-type and control the include path (i.e. writing content). The impact of a successful attack is privilege escalation to administrative power. Please update to Apache Sling Engine >= 2.14.0 and enable the "Check Content-Type overrides" configuration option.

Affected

ProductAffectedFixed inSource
Apache Sling Engine – < 2.14.02.14.0CNA
sling< 2.14.02.14.0CISA-ADP

Scores by source

NVD9.0CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
apache (CNA)8.0CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: total

References

advisorylists.apache.org/thread/hhp611hltby3whk03vx2mv7cmy3vs0okrefopenwall.com/lists/oss-security/2023/04/18/6