Paper/Archive/CVE-2022-41892

CVE-2022-41892

archesproject arches — Arches vulnerable to SQL Injection

Description · from the CVE record

Arches is a web platform for creating, managing, & visualizing geospatial data. Versions prior to 6.1.2, 6.2.1, and 7.1.2 are vulnerable to SQL Injection. With a carefully crafted web request, it's possible to execute certain unwanted sql statements against the database. This issue is fixed in version 7.12, 6.2.1, and 6.1.2. Users are recommended to upgrade as soon as possible. There are no workarounds.

Affected

ProductAffectedFixed inSource
arches<= 6.1.2–CNA
arches>= 6.2.0, < 6.2.1–CNA
arches>= 7.0.0, < 7.1.2–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)8.6CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: partial

References

refgithub.com/archesproject/arches/security/advisories/GHSA-gmpq-xrxj-xh8m