Paper/Archive/CVE-2022-39297

CVE-2022-39297

melisplatform melis-cms — Deserialization of untrusted data in MelisCms

Description · from the CVE record

MelisCms provides a full CMS for Melis Platform, including templating system, drag'n'drop of plugins, SEO and many administration tools. Attackers can deserialize arbitrary data on affected versions of `melisplatform/melis-cms`, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication. Users should immediately upgrade to `melisplatform/melis-cms` >= 5.0.1. This issue was addressed by restricting allowed classes when deserializing user-controlled data.

Affected

ProductAffectedFixed inSource
melis-cms<= 5.0.0–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)7.7CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
CISA ADPSSVCExploitation: none · Automatable: no · Technical impact: total

References

refgithub.com/melisplatform/melis-cms/security/advisories/GHSA-m3m3-6gww-7gj9refgithub.com/melisplatform/melis-cms/commit/d124b2474699a679a24ec52620cadceb3d4cec11