Paper/Archive/CVE-2021-4374

CVE-2021-4374

ValvePress WordPress Automatic Plugin — WordPress Automatic Plugin <= 3.53.2 - Unauthenticated Arbitrary Options Update

Description · from the CVE record

The WordPress Automatic Plugin for WordPress is vulnerable to arbitrary options updates in versions up to, and including, 3.53.2. This is due to missing authorization and option validation in the process_form.php file. This makes it possible for unauthenticated attackers to arbitrarily update the settings of a vulnerable site and ultimately compromise the entire site.

Affected

ProductAffectedFixed inSource
WordPress Automatic Plugin< 3.53.33.53.3CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Wordfence (CNA)9.1CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
CISA ADPSSVCExploitation: none · Automatable: yes · Technical impact: partial

References

refwordfence.com/threat-intel/vulnerabilities/id/d0567dc8-7a4c-42f4-bf45-f31a8efaa354?source=cverefblog.nintechnet.com/critical-vulnerability-fixed-in-wordpress-automatic-plugin